Авторские статьи об OpenSource

Ubuntu готовится избавиться от Qt4.


Разработчики Canonical в рамках Ubuntu 18.10 начнут работу по избавлению от зависимостей от Qt4 вслед за папой Debian GNU/Linux 10 Buster.

Старое наследие всегда тяжело поддерживать и если апстрим его уже не поддерживает, то какой смысл вкладывать силы ниже по течению?

В репозиторий не будут приниматься пакеты, которые прямо или косвенно зависят qt4-x11. На данный момент существует 330 пакета, которые зависят от qt4, и среди них с громкими именами: LibreOffice (libreoffice-kde), LightDM и весь стек KDE 4. Разработчикам нужно обновить свои детища до использования фреймворка Qt 5, иначе пакет будет удалён в рамках релиза Ubuntu 19.04.

Текущий флагман, который появится в апреле 2018, Ubuntu 18.04 LTS Bionic Beaver не будет делать резких движений и в нём qt4 поддерживается в полной мере до 2018 + 5 лет = 2023 года.

Самое большое влияние от отказа qt4 понесут проекты Kubuntu и Lubuntu Next, так как в них qt основной фреймворк, в отличии от Ubuntu, которая стала GNOME/GTK.

Будущие обои Ubuntu 18.04 Bionic Beaver

    Twitter   


Разделы

Главная
Новости
Ворох бумаг
Видео Linux
Игры в Linux
Безопасность
Статьи о FreeBSD
Статьи об Ubuntu
Статьи о Snappy
Статьи об Ubuntu Phone
Статьи о Kubuntu
Статьи о Xubuntu
Статьи о Lubuntu
Статьи об Open Source
Карта сайта

Лучшее на сайте:

1С под Linux.   Ускорение Ubuntu.   21 пример iptables.   Цикл статей о Ceph.   Убунту в дикой среде.   Ubuntu Linux на SSD.   Ubuntu для блондинок.   Поддержка железа в Linux.   BTSync на службе у админа.   Андроид программы в Ubuntu.   Прокидывание портов для p2p.   Анти СПАМ в Postfix.  



Круги Гугл Ада.


Группа поддержки